Bug 1216 - AutoDockTools-1.5.4 fails to start
: AutoDockTools-1.5.4 fails to start
Status: RESOLVED WORKSFORME
Product: MGL Applications
Classification: Unclassified
Component: ADT
: 4.0.1
: PC Windows XP
: P5 blocker
Assigned To: mgltools
:
:
:
  Show dependency treegraph
 
Reported: 2011-01-06 07:40 PST by Hanoch
Modified: 2012-01-13 12:27 PST (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hanoch 2011-01-06 07:40:38 PST
I have installed AutoDockTools-1.5.4 on my PC but when I try to start it I get
an error message and the tool fails to start. The error message follows. When I
press "enter" as requested both the graphic window and the window in which the
error message appear disapear.


C:\Documents and Settings\hanoch>set MGLPYTHONPATH=C:\Program Files\MGLTools
1.5
.4

C:\Documents and Settings\hanoch>"C:\Python25\python.exe" "C:\Program
Files\MGLT
ools 1.5.4\MGLToolsPckgs\AutoDockTools\bin\runAdt.py"
Run AutoDockTools from C:\Program Files\MGLTools
1.5.4\MGLToolsPckgs\AutoDockToo
ls
Resource file used to customize PMV: C:\Documents and
Settings\hanoch\.mgltools\
1.5.4\Pmv\_pmvrc
Traceback (most recent call last):
  File "C:\Program Files\MGLTools
1.5.4\MGLToolsPckgs\AutoDockTools\__init__.py"
, line 373, in runADT
    title=title, withShell= not interactive, verbose=False)
  File "C:\Program Files\MGLTools 1.5.4\MGLToolsPckgs\Pmv\moleculeViewer.py",
li
ne 315, in __init__
    verbose=verbose, trapExceptions=trapExceptions)
  File "C:\Program Files\MGLTools 1.5.4\MGLToolsPckgs\ViewerFramework\VF.py",
li
ne 345, in __init__
    verbose=verbose)
  File "C:\Program Files\MGLTools
1.5.4\MGLToolsPckgs\ViewerFramework\VFGUI.py",
 line 277, in __init__
    cnf = {"addScenarioButton": False})
  File "C:\Program Files\MGLTools 1.5.4\MGLToolsPckgs\DejaVu\Viewer.py", line
67
5, in __init__
    cp = ClippingPlane(self.rootObject, i, self)
  File "C:\Program Files\MGLTools 1.5.4\MGLToolsPckgs\DejaVu\Clip.py", line 42,
in __init__
    self.id = self.clipPlaneNames[num]
IndexError: list index out of range
hit enter to continue
Comment 1 Ruth Huey 2011-01-06 08:52:19 PST
This problem is caused by an issue in this version of DejaVu/Clip.py not
AutoDockTools.
Comment 2 Sargis Dallakyan 2011-01-06 09:55:47 PST
*** Bug 1217 has been marked as a duplicate of this bug. ***
Comment 3 Sargis Dallakyan 2011-01-06 10:03:31 PST
Thanks for the bug report. Please try our Nightly Builds to see if it has been
fixed there: http://mgltools.scripps.edu/downloads/nightly
Comment 4 Sargis Dallakyan 2011-04-15 09:45:34 PDT
*** Bug 1228 has been marked as a duplicate of this bug. ***
Comment 5 Sargis Dallakyan 2011-09-06 16:45:41 PDT
*** Bug 1263 has been marked as a duplicate of this bug. ***
Comment 6 Sargis Dallakyan 2011-09-06 16:46:46 PDT
*** Bug 1272 has been marked as a duplicate of this bug. ***
Comment 7 Jian Yang 2012-01-12 08:05:32 PST
the running results are same as the following examples