ADL: Problems to install MGLTools-1.4.6

Sargis Dallakyan sargis at scripps.edu
Tue Oct 16 10:19:23 PDT 2007


Jordi wrote:
> Hello,
> 
> I am trying to install MGLTools-1.4.6 on a dual opteron machine with RHEL4.4_x86-64. The previous MGLTools_1.4.5_i86 version installed and runs without problems, however I had no luck installing this new version.
> 
> I got an "Error installing MGLTools binaries!" message whenever I tried the 64 or 32 bits binaries (MGLTools-1.4.6-Linux-x86-64-Install and MGLTools-1.4.6-Linux-x86-Install). I expected that for the 64 bit version because of the GLIBC_2.4 problem, but I thought the 32 bit version would work (as before). As recommended in the troubleshooting web page, I did run MGLTools-1.4.6/i86(_64)Linux2/bin/python, and what I got is:
> 
> Then, as also recommended in the same troubleshooting page, I tried the tarballs and again I got the following error messages:
> 
> 
> [root at sauron mgltools_x86_64Linux2_1.4.6]# source install.sh -d /usr/local/Programs/MGLTools
> 
> ...extrainclude/tkPlatDecls.h
> Python installed, please wait for the rest of MGLTools to be installed
> Running /usr/local/Programs/MGLTools/x86_64Linux2/bin/python -O Tools/install.py
> /usr/local/Programs/MGLTools/x86_64Linux2/bin/python: /lib64/tls/libc.so.6: version `GLIBC_2.4' not found (required by /usr/local/Programs/MGLTools/x86_64Linux2/bin/python)

Thanks for the bug report. I've updated MGLTools-1.4.6-Linux-x86-Install to fix 
this problem:
http://mgltools.scripps.edu/downloads/tars/releases/REL1.4.6/MGLTools-1.4.6-Linux-x86-Install

The problem was in the archosv script that now returns i86 instead of x86_64.

Thanks,
Sargis


More information about the autodock mailing list