ADL: MGLTools-1.4.6 with "Segmentation fault" on CentOS?

Sargis Dallakyan sargis at scripps.edu
Mon Mar 3 09:57:42 PST 2008


D Wang wrote:
> Hi, all
> I've read about the problems described in the FAQ page on the website about
> seg fault on autodock3, I'm now experiencing the similar problem on my
> CentOS 4.6 but with adt:
> "
>          [rw at daniel /]$ adt
>          setting PYTHONHOME environment
>          Run AutoDockTools from /usr/local/MGLTools-1.4.6
> /MGLToolsPckgs/AutoDockTools
>          MSMSLIB 1.4.4 started on daniel
>          Copyright M.F. Sanner (March 2000)
>          Compilation flags
>          Segmentation fault
>          [rw at daniel /]$
> "
> I tried "ulimit -s unlimited", updated the system using "yum update", but
> they didn't work. And when I shifted to the more recent ver 5.1 of CentOS,
> beside the "Segmentation fault", I also kept receiving "libGL warning: 3D
> driver claims to not support visual 0x4b". I'm using Intel's integrated
> 855GM/GME. I suspected there might be some problem with mesa. But hope
> you're not suggesting upgrading my mesa, cuz I've tried but failed compiling
> and upgrading mesa to ver7.0 or ver7.0.2 many many times. (mesa-libGL
> ver6.5.1 was with CentOS ver5.1, and mesa ver6.2.1 with CentOS ver4.6)

Does Segmentation fault happen on startup or only when you perform certain 
tasks? I'd recommend using hardware driver provided by your graphics card 
manufacturer. I put the link to Intel drivers here:
http://mgltools.scripps.edu/documentation/how-to/hardware-opengl

See also:
http://www.cgl.ucsf.edu/chimera/graphics/graphicsbugs.html

Thanks
Sargis


More information about the autodock mailing list