ADL: MGLTools TclError: Togl: couldn't get visual RESOLVED

Naba nabajyoti.goswami at gmail.com
Wed Jan 14 10:31:58 PST 2009


Dear Autodock Users,

This is in general interest for those, who are facing the error "*TclError:
Togl: couldn't get visual*" after MGLTools intallation.

Due to the misconfigured NVIDIA graphics driver on fedora 10, AutoDockTools
and chimera were not properly installed. Though Chimera was installed, but
exhibiting the warning "Xlib:  extension "XFree86-DRI" missing on display
":0.0"." But ADT was not able to installed at all.
Following the link http://www.cgl.ucsf.edu/chimera/1.2470/linux.html, I have
resolved the problem by reconfiguring my nvidia graphics driver. For
instance I have downloaded the packages nvidia-xconfig-1.0.tar.gz and the
driver  "NVIDIA-Linux-x86-180.22-pkg1.run" from the official nvidia website
and closing all x appications I ran "sh NVIDIA-Linux-x86-180.22-pkg1.run" in
a command terminal. It initialized and installed the graphics driver again.
After that I have untarred the nvidia-xconfig-1.0.tar.gz and typed "make" to
configure. It will provide the executable nvidia-xconfig file which can be
re-written by typing "./nvidia-xconfig" in a terminal. Finally rebooting the
system shows excellent enhancement in 3D graphics without any error message
during any openGL applications including ADT or Chimera.

With Regards,
Nabajyoti Goswami












Ph.D Student.
Center for Biotechnology,
Anna University,
Chennai-600025
Tamil Nadu.
Mobile: 09840487093
http://www.annauniv.edu/BiotechCentre/index.php


More information about the autodock mailing list