ADL: "list index out of range" Error on OSX

Thomas Coudrat thomas.coudrat at umontreal.ca
Wed Jan 21 08:12:16 PST 2009


Hello all,

I have been an academic user of Autodock & AutodockTools for a while now.
Recently i tried to install it on a new mac, and i have had a lot of trouble
to get it to work.

I get an error when i try to open a .dlg file, here is what i get :

******************************
Traceback (most recent call last):
  File "/Library/MGLTools/1.5.2/MGLToolsPckgs/ViewerFramework/VF.py", line
716, in tryto
    result = apply( command, args, kw )
  File
"/Library/MGLTools/1.5.2/MGLToolsPckgs/AutoDockTools/autoanalyzeCommands.py",
line 2840, in doit
    d.readDlg(dlgFile)
  File "/Library/MGLTools/1.5.2/MGLToolsPckgs/AutoDockTools/Docking.py",
line 74, in readDlg
    dlo = DockingLogObject(self, dlgFile)
  File "/Library/MGLTools/1.5.2/MGLToolsPckgs/AutoDockTools/Docking.py",
line 341, in __init__
    self.dpo = self._buildDpo(parser.dpfLines)
  File "/Library/MGLTools/1.5.2/MGLToolsPckgs/AutoDockTools/Docking.py",
line 376, in _buildDpo
    dpo._parse(lines)
  File
"/Library/MGLTools/1.5.2/MGLToolsPckgs/AutoDockTools/DockingParameters.py",
line 706, in _parse
    self['include_1_4_interactions']['value'] = self._get_val(values[0])
IndexError: list index out of range
*********************************

I use an Intel based OSX 10.5.2, which comes with a python version 2.5.1.
I downloaded autodock (binaries) for 10.4, and MGLTools (binaries) for 10.5.
I added the PATH : /Library/MGLTools/1.5.2/bin to my newly created .bashrc.

With this it should work, but i tried many many different possibilities,
installing new python versions, installing from source code etc... I ended
up reinstalling my whole system (OSX 10.5) in order to get a fresh start,
and i still have the same problem.

Note that i tried to execute the scripts only (summarize_results4.py) and i
get the same problem. I also tried out the same scripts on a red hat linux,
and i worked fine. The problem might be python related, but i can't figure
it out.

The problem seems to occur when the .dlg files are read.

I also browsed through the internet to find a solution, but without any
positive result.

I would really appreciate it if you could help me, hope to get this fixed
soon.

Thank you,


Thomas.


More information about the autodock mailing list