ADL: ADT: "no non-bonded atoms"/"Divide by zero" error

FireIceEarth jdi1g13 at soton.ac.uk
Fri Dec 13 01:29:45 PST 2013


Some fantastic person called Ruth PM'd me with some thoughts, editing my
post. I realise I really didn't help myself and gave very little information
to go on!

I'm working on Mac, OS 10.9, the other computer was OS 10.6 and I've now
found my saved files in a weird place. I'll try to run them and post what
happens. 



Here's what Ruth said (in case someone else googles about that error).
Thanks Ruth!

Hi all,

I'm pretty new to AutoDock and could use some help. I've used ADT and 4.2
before, but never had to set it up on a new computer before, I can't get it
to run!
What Operating System is your new computer running?

It runs in an older build of AutoDock on someone else's computer,
but not 4.2 on that same computer. (what OS is that computer using?)

When I load my macromolecule .pdb
I get the warning "initilizing
[receptor].pdb": -contains no non-bonded atoms" on clicking Okay
Although this appears as a 'warning message', in this case it is just a
(harmless!) report to you.

it then tries to make the pdbqt but nothing is actually made.
Please describe what steps you used here.
(for example, after reading in the pdb file, did you:
                      remove waters +  add (all) hydrogens?
                      use Grid->Macromolecule->Choose?
                      
(it also had trouble with some K that it didn't know the charge for, a
temporary fix was to
remove them, but I need to find out how to tell it what charges metals
should have).
You will have to decide what charge you want to use for K atoms and set it
by editing your pdbqt file.  
The pdbqt file will have 0. for K atoms by default.

Does anyone know what that error means and how to overcome it?
Google doesn't find anything.

I used Raccoon to make pdbqts of my ligand and receptor and tried to run
autogrid, it flashed up with a progress timer which disappeared again.
Checking the folder, no new files were made.
<again, these files are probably on your computer in some unexpected
directory>

Are you able to start autogrid on your new computer in a terminal shell?
Type the path to your local copy of autogrid4 without its required
arguments.
You should see something like this in your terminal shell:

rhuey.saul 267% ./autogrid4
usage: AutoGrid 	-p parameter_filename
			-l log_filename
			-d (increment debug level)
			-h (display this message)
			--version (print version information, copyright, and license)


When I looked at the terminal
it said that a "divide by zero issue had been avoided

I've tried a number of tutorials and guides but nothing's working. I tried
to use prepare_receptor4.py but the terminal just says

"setting PYTHONHOME environment
adding gasteiger charges to peptide"

Then my commandline comes back. No new files get made. Argh!
IF you are using a mac computer, use the finder to search for the receptor
pdbqt file.
(if prepare_receptor4.py ran successfully, it may have output the pdbqt file
in an odd place)

Any help would be much appreciated.

           Best wishes,
              Ruth




--
View this message in context: http://autodock.1369657.n2.nabble.com/ADT-no-non-bonded-atoms-Divide-by-zero-error-tp7578314p7578318.html
Sent from the AutoDock mailing list archive at Nabble.com.


More information about the autodock mailing list