ADL: Error in autogrid running

Ruth Huey rhuey at scripps.edu
Fri Dec 26 10:50:47 PST 2014


Hi,
This error message suggests two possibilities:
 1->that you may not yet have downloaded and installed the autogrid4 and autodock4 executables.
  These executables are NOT included in MGLToolsPckgs. Instead they are available here: 
          http://autodock.scripps.edu/downloads/autodock-registration/autodock-4-2-download-page

 2-> IF you HAVE already installed them, the problem may be that to use them from AutoDockTools, you must specify the 
complete path to where you have put  them on your local computer:
btw: -put all 3 of the input files you have already prepared for your specific docking in the one directory.
  - yourligand.pdbqt, yourreceptor.pdbqt, yourgridparameterfile.gpf 

Then start ADT and follow these steps:
1. Click on  Run->Run AutoGrid....     #<- to open the 'Run AutoGrid' form
2. In the 'Run AutoGrid' form, use the 4 'Browse' buttons to locate and select your input files: 
    i.e. click the Browse buttons to navigate through your local files as needed to find and specify:
          -Working Directory   (your local directory containing the prepared ligand, receptor, gpf and dpf files.)
          -Path to your local autogrid4 executable AND its name 
          -Path to your parameter filename AND its name
          -Path to your log filename AND its name
3. Verify that the 'Cmd' entry resembles something like this:
        ./autogrid4 -p hsg1.gpf -l hsg1.glg &
THEN when you have specified all the needed parts, press the Launch button.

       Best wishes,
           Ruth
________________________________________
From: autodock-bounces at scripps.edu [autodock-bounces at scripps.edu] On Behalf Of Xue Cai [ceciliacaixue at gmail.com]
Sent: Thursday, December 25, 2014 1:33 AM
To: autodock at scripps.edu
Subject: ADL: Error in autogrid running

Hi,
This is the error that I encountered when running AutoGrid.
My system is MAC OS X.
It says:

Traceback (most recent call last):
  File "/Library/MGLTools/1.5.6/MGLToolsPckgs/ViewerFramework/VF.py", line 898, in tryto
    result = command( *args, **kw )
  File "/Library/MGLTools/1.5.6/MGLToolsPckgs/AutoDockTools/autostartCommands.py", line 964, in doit
    ps = subprocess.Popen(args)
  File "/Library/MGLTools/1.5.6/lib/python2.5/subprocess.py", line 594, in __init__
    errread, errwrite)
  File "/Library/MGLTools/1.5.6/lib/python2.5/subprocess.py", line 1097, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory


what should I do?
Thanks!
Merry Christmas!

Xue Cai
________________________________________________
--- ADL: AutoDock List  --- http://autodock.scripps.edu/mailing_list ---


More information about the autodock mailing list