ADL: Problem running Autodock, autogrid and Vina in Pymol

Juan Munoz-Garcia juan.munoz-garcia at bioch.ox.ac.uk
Thu Feb 27 09:39:06 PST 2014


Dear Autodock Users,

I'm getting the following error when trying to run either autodock, autogrid or vina within pymol (autodock/vina plugin)

Exception in thread Thread-2:
Traceback (most recent call last):
  File "/sw/bin/lib/python2.7/threading.py", line 810, in __bootstrap_inner
    self.run()
  File "/Users/jcmunoz/.pymol/startup/autodock.py", line 200, in run
    self.status_line.configure(text = self.log_text)
  File "/sw/bin/lib/python2.7/lib-tk/Tkinter.py", line 1262, in configure
    return self._configure('configure', cnf, kw)
  File "/sw/bin/lib/python2.7/lib-tk/Tkinter.py", line 1253, in _configure
    self.tk.call(_flatten((self._w, cmd)) + self._options(cnf))
RuntimeError: main thread is not in main loop

However, when I run either of them from the command line I don't have any problem. I'm working on Mac OS X. I get the same error in both OS X 10.7.5 and 10.9.2.

Does anyone have any idea of how to solve this issue?

Thank you very much.
Regards

Juan C. Muñoz-García, PhD
Biomembrane Structure Unit
Department of Biochemistry
University of Oxford
South Parks Road
Oxford OX1 3QU





More information about the autodock mailing list