ADL: Segmentation fault when trying to run AGFR on linux

Michel Sanner sanner at scripps.edu
Thu Oct 8 09:38:46 PDT 2020


Hi Matthew

It looks like AutoGrid4 is crashing with a segmentation fault. Unfortunately I can do not have access to this OS so I can’t really reproduce your problem.
I suggest you go to the folder reported in the error message  /home/longorefisher/GQI263GA328L/Test_All/R1C1/Receptor
and run the autogrid command line with  high verbosity level to get a hint where it crashes:


  *   /home/longorefisher/ADFRsuite-1.0/bin/autogrid4 -d 9 -p rigidReceptor.gpf -l rigidReceptor.glg

Or try to run in the debugger


  *   Gdb /home/longorefisher/ADFRsuite-1.0/bin/autogrid4
  *   Run -d 9 -p rigidReceptor.gpf -l rigidReceptor.glg

Let me know if this gives you some hints.

-Michel

From: <autodock-bounces at scripps.edu> on behalf of Matthew Fisher <matthew.fisher at stcatz.ox.ac.uk>
Reply-To: "autodock at scripps.edu" <autodock at scripps.edu>
Date: Thursday, October 8, 2020 at 6:23 AM
To: "autodock at scripps.edu" <autodock at scripps.edu>
Subject: ADL: Segmentation fault when trying to run AGFR on linux

Dear all,

I'm currently using ADFR & AGFR on linux, both on WSL and Pop-OS. On WSL I've (unusually) had no problems at all. However, on Pop-OS, when I try to run AGFR, about 2 in 3 times I get the following error message immediately after maps are computed (the other 1 in 3 we get a successful run).


ERROR: running autogrid failed in /home/longorefisher/GQI263GA328L/Test_All/R1C1/Receptor.
  "/home/longorefisher/ADFRsuite-1.0/bin/autogrid4" -p rigidReceptor.gpf -l rigidReceptor.glg
Segmentation fault (core dumped)
.

Traceback (most recent call last):
  File "/home/longorefisher/ADFRsuite-1.0/CCSBpckgs/ADFR/bin/runAGFR.py", line 59, in <module>
    runner(**kw)
  File "/home/longorefisher/ADFRsuite-1.0/CCSBpckgs/ADFR/utils/runAGFR.py", line 994, in __call__
    raise RuntimeError('ERROR: AutoGrid failed to run in %s'%gc.folder)
RuntimeError: ERROR: AutoGrid failed to run in /home/longorefisher/GQI263GA328L/Test_All/R1C1/Receptor


Has anyone got any ideas as to what might be going on?

Thanks in advance,

Matthew Fisher


________________________________________________
--- ADL: AutoDock List  --- http://autodock.scripps.edu/mailing_list ---



More information about the autodock mailing list